Error (phpBB 2/PHP 5)

Aveţi probleme cu serverul Apache, cu interpretorul de PHP sau cu baza de date MySQL? Aici găsiţi informaţii despre servere free unde se poate instala forumul phpBB, despre cele contra cost în forumul Reclamă.
ynfonet
Nou venit
Nou venit
Mesaje: 9
Membru din: 27-Aug-2005, 17:59:37

Error (phpBB 2/PHP 5)

Mesaj de ynfonet » 31-Aug-2005, 09:51:55

Versiunea PhpBB-2.0.17 este compatibila completa cu versiunea Php 5?

Inclusiv versiunea in limba romana cu diacritice?

Sau care este ultima versiune PhpBB compatibila cu Php 5

ori care este combinatia optima completa intre PhpBB si Php?

Multumesc.

flowers
Administrator
Administrator
Mesaje: 4641
Membru din: 03-Iun-2004, 16:50:34
MOD: Nu
Server: Windows
Nivel phpBB: Mediu
Nivel php: Mediu
Localitate: Bucureşti, România
Contact:

Mesaj de flowers » 31-Aug-2005, 11:01:54

Ai mai sus o varianta phpBB compatibila cu PHP 5.
Varianta standard phpBB merge bine pe ultima versiune de PHP 4.
docs\README.html
7. PHP compatibility issues

phpBB is no longer supported on PHP3 due to several compatibility issues and we recommend that you upgrade to the latest stable release of PHP4 to run phpBB.

Please remember that running any application on a developmental version of PHP can lead to strange/unexpected results which may appear to be bugs in the application (which may not be true). Therefore we recommend you upgrade to the newest stable version of PHP before running phpBB 2. If you are running a developmental version of PHP please check any bugs you find on a system running a stable release before submitting.

This board has been developed and tested under Linux and Windows (amongst others) running IIS and Apache using MySQL 3.23 and 4.0.0, MSSQL Server 2000, MS Access 2000 and XP and PostgreSQL 7.x. Versions of PHP used range from 4.0.6 to 4.3.8 without problem. There may be unconfirmed issues with PHP 4.0.1 including patch level releases. If you experience problems with phpBB and have this PHP version installed it is recommended you upgrade it before posting bug reports.

With the recent release of the official version of PHP 5, people and hosts may be switching to the latest PHP version. At this moment, the phpBB Team does not officially support running phpBB on PHP 5, as phpBB2.0.x was not written with PHP 5 in mind. However, many users have reported using it sucessfully on PHP 5 having made a configuration change in PHP to enable support for the deprecated HTTP_*_VARS arrays which is turned off by default in new PHP 5 installations. The relevant configuration option is register_long_arrays and it is decribed in the PHP Manual. phpBB 2.0.x makes use of these arrays in order to maintain backwards compatibility with early versions of PHP 4.x which is part of the original specification.
For this reason we do not support PHP 5 as platform for phpBB. It has been reported working, so you can try it. It's a risk you will be taking though.

bobo32
Nou venit
Nou venit
Mesaje: 3
Membru din: 25-Oct-2005, 13:31:44
MOD: Nu
Server: Windows
Nivel phpBB: Mediu
Nivel php: Mediu
Localitate: Cluj-Napoca
Contact:

Mesaj de bobo32 » 30-Oct-2005, 11:25:56

Fatal error: Only variables can be passed by reference in /home/subsro/public_html/forum/posting.php on line 555


eroarea asta o primesc la forumul meu de pe http://www.subs.ro/forum cand incerc sa postez... host-ul e pe rds.

[edit="flowers"]Subiect unit cu altul care dezbate aceeaşi problemă.[/edit]

Scrie răspuns

Înapoi la “Server”

Cine este conectat

Utilizatori ce ce navighează pe acest forum: Niciun utilizator înregistrat și 2 vizitatori