Mutare forum pentru update de la 3.0.2 la 3.0.11

Rezolvări la problemele apărute la instalarea, actualizarea sau conversia forumului phpBB 3.0.x.
Reguli forum
Aveti o problema si vreti sa primiti ajutor? Click aici ! Nu uitati si de regulamentul forumului !
Închis
Avatar utilizator
danpetreanu
Junior
Junior
Mesaje: 33
Membru din: 19-Sep-2008, 22:50:29
MOD: Nu
Server: Windows
Nivel phpBB: Mediu
Nivel php: Mediu
Localitate: Bucuresti
Contact:

Mutare forum pentru update de la 3.0.2 la 3.0.11

Mesaj de danpetreanu » 15-Dec-2012, 21:28:25

URL forum: sinucigasi.ro
Versiunea phpbb 3: 3.0.2
Daca forumul a fost instalat recent sau reprezinta un update/upgrade/conversie ? Nu este cazul
Ati folosit un wizard de instalare furnizat de firma de gazduire pentru instalare? Nu este cazul
MODurile instalate: Nu este cazul
De cand a aparut problema semnalata ? Acum vreo 30 de zile la o tentativa de upgrade
Nivelul vostru de experienta in instalarea/utilizarea/administrarea phpbb: 4/10

Template-ul folosit: coffee time
Limba/limbile instalate: ro
Versiunea de PHP: 5.2
Tipul si versiunea serverului pentru baza de date: MySQL(i) 5.0.96


Salut voios de pionier!

Situatia sta cam asa: pentru n-am avut vreme si am fost un ignorant, n-am actualizat forumul la timp iar acum intampin o situatie care mi se pare cumva bizara. N-am avut nicio problema in a citi si proceda la update conforum knoledge base-ului de pe phpbb.com atat varianta automanta , si pentru ca n-a mers, si cea manuala.

Dupa cateva ore de cercetare am inteles ca PHPBB 3.0.11 cere minim PHP 5.3.2 moment in care am intrebat firma de hosting (rohost) ce versiune de PHP este pe server - 5.2. Sugestia dumnealor a fost sa mutam domeniul pe un alt server cu o versiune de PHP mai mare. Dupa ce am notificat in scris firma de hosting ca-mi dau acordul pentru mutare si am confirmat ca mi-am facut back-up la tot continutul FTP-ului mi se raspunde intr-un mail asa:

Un server cu o versiune superioara de php implica mutarea pe un server ce ruleaza cu Fast CGI diferit de actualul server ce ruleaza cu Apache 2.0 Handler.
Sunt diferente intre cele doua server-e adica:

1. Scripturile php ruleaza cu user-ul contului dvs pe Fast CGI iar pe actualul server ruelaza cu user-ul nobody.
2. Dupa mutare nu vor mai putea fi folosite php_flag si php_value in fisierele htaccess.

Daca doriti sa mutam contul, va rog sa reveniti insa recomand sa verificati daca solutia propusa este buna pentru pagina dvs.


Si aici am intrat in ceata. Dupa vreo doua ore de cercetare ( http://support.tigertech.net/php-value http://php.net/manual/en/configuration.changes.php) am inteles ca lipsa php_flag si php_value poate fi "dreasa" din php.ini.

Carevasazica, in lumina asta, ce sa fac? Mut forumul? daca da, cam la ce probleme ar trebui sa ma astept?

Va foarte multumesc domnilor!
Cu respect,
DanP

flowers
Administrator
Administrator
Mesaje: 4641
Membru din: 03-Iun-2004, 16:50:34
MOD: Nu
Server: Windows
Nivel phpBB: Mediu
Nivel php: Mediu
Localitate: Bucureşti, România
Contact:

Re: Mutare forum pentru update de la 3.0.2 la 3.0.11

Mesaj de flowers » 16-Dec-2012, 02:17:45

Muta fara grija, n-ai treaba cu alea.

Avatar utilizator
Alex-
Membru
Membru
Mesaje: 238
Membru din: 29-Mar-2012, 20:17:49
Versiune: 3.0.12
MOD: Da
Server: UNIX/Linux
Nivel phpBB: Mediu
Nivel php: Puţin experimentat
Localitate: București
Contact:

Re: Mutare forum pentru update de la 3.0.2 la 3.0.11

Mesaj de Alex- » 16-Dec-2012, 21:24:52

Poţi face upgrade şi la 3.0.8 şi după la 3.0.11 .. doar că trebuie să fi antent şi să ai backup.
Spaţiu publicitar gratuit : Dacă vrei să ai aici o reclamă sună la 112 .\
http://school-board.pro - forum şcolar !
ID vechi: Af Medaih

Avatar utilizator
danpetreanu
Junior
Junior
Mesaje: 33
Membru din: 19-Sep-2008, 22:50:29
MOD: Nu
Server: Windows
Nivel phpBB: Mediu
Nivel php: Mediu
Localitate: Bucuresti
Contact:

Re: Mutare forum pentru update de la 3.0.2 la 3.0.11

Mesaj de danpetreanu » 16-Dec-2012, 23:28:56

Update la 3.0.8 nu m-ar ajuta in niciun fel, ar fi irelevant. Problema mea este serverul cu php 5.2 care nu "haleste" phpbb 3.0.11...

Back-up am la tot ce se gaseste pe ftp inclusiv, separat, baza de date pentru orice eventualitate. Ma ingrijoreaza doar faptul ca o sa ma lovesc de niste chestii care o sa-mi tina offline forumul o perioada ma lunga pentru n-am prea mult timp la dispozitie sa-i dedic.

In cel mai rau caz, o sa-l reinstalez de la zero, cu 3.0.11 si fac update la baza de date, oricum vreau sa schimb si template-ul daca tot fac deranj.

Apreciez raspunsurile dvs, le iau in calcul insa va rog sa-mi permiteti sa mai astept cateva pareri inainte de a purcede la mutare ;)

Va multumesc!
DanP

Avatar utilizator
Ivan Petre Paul
Moderator
Moderator
Mesaje: 4046
Membru din: 26-Aug-2009, 01:13:39
Versiune: 3.1.10
MOD: Da
Server: UNIX/Linux
Nivel phpBB: Experimentat
Nivel php: Puţin experimentat
Localitate: Brașov
Contact:

Re: Mutare forum pentru update de la 3.0.2 la 3.0.11

Mesaj de Ivan Petre Paul » 17-Dec-2012, 02:44:14

Dacă îmi amintesc bine, cred că valorile php_ nu mai trebuiesc scrise în .htaccess, ci pot fi modificate direct în php.ini. Asta înseamnă că nu vei avea probleme dacă vei muta forumul. :)
phpBB România will rise again. Soon.. Stay close! @phpbb.ro

Avatar utilizator
danpetreanu
Junior
Junior
Mesaje: 33
Membru din: 19-Sep-2008, 22:50:29
MOD: Nu
Server: Windows
Nivel phpBB: Mediu
Nivel php: Mediu
Localitate: Bucuresti
Contact:

Re: Mutare forum pentru update de la 3.0.2 la 3.0.11

Mesaj de danpetreanu » 17-Dec-2012, 21:15:15

Ok, daca am lamurit-o cu php_flag si php_value, care-i treaba cu: "Scripturile php ruleaza cu user-ul contului dvs pe Fast CGI iar pe actualul server ruelaza cu user-ul nobody." ? Aici nu prea inteleg... :oops: Ce se vrea a insemna asta? Cum influenteaza userul contului scripturile php odata ce mut forumul? Cumva are legatura cu userul bazei de date?

Avatar utilizator
bogdan
Administrator
Administrator
Mesaje: 10888
Membru din: 18-Oct-2002, 12:14:27
Versiune: 3.0.11
MOD: Da
Server: UNIX/Linux
Nivel phpBB: Experimentat
Nivel php: Mediu
Localitate: Bucuresti
Contact:

Re: Mutare forum pentru update de la 3.0.2 la 3.0.11

Mesaj de bogdan » 18-Dec-2012, 20:57:56

Nu are legatura cu userul bazei de date ci are cu userul serverului unix/web.
danpetreanu scrie:Update la 3.0.8 nu m-ar ajuta in niciun fel, ar fi irelevant. Problema mea este serverul cu php 5.2 care nu "haleste" phpbb 3.0.11...
Unde ai citit tu asta?!?

Vezi: https://www.phpbb.com/support/documenta ... ements.php

visualstorm
Membru
Membru
Mesaje: 219
Membru din: 29-Apr-2007, 00:12:47
Versiune: 3.0.12
MOD: Da
Server: UNIX/Linux
Nivel phpBB: Experimentat
Nivel php: Mediu

Re: Mutare forum pentru update de la 3.0.2 la 3.0.11

Mesaj de visualstorm » 20-Dec-2012, 05:33:48

Asa cum reiese din linkul postat de catre Bogdan, phpbb 3.0.11 are cerinte minime pentru PHP 4.3.3
Pentru versiunile uterioare ale phpbb, cum ar fi cea in dezvoltare - phpBB 3.1 "Ascraeus" - este necesara instalarea minimala a PHP 5.3.3, insa nu este cazul tau.
Nu te chinui sa muti forumul degeaba, va functiona foarte bine si cu PHP 5.2
Daca totusi o faci, acel Fast CGI este instalat pe server pentru a trata cererile mai rapid, preluand mai multe procese simultan. Daca ai un forum mare, cu vizitatori multi, te ajuta sa cresti viteza prin stabilirea variabilei de memorie corespunzatoare in fisierul config.php, aflat in radacina forumului.
Variabila implicita este

Cod: Selectaţi tot

 $acm_type = 'file';
Pentru a vedea ce accelerator ai instalat pe server mergi in panoul de administrare, pagina General>Informatii PHP.
Cele mai folosite variante pentru un forum ar fi:
1.Alternative PHP Cache (APC)
2. eAccelerator
3. ionCube PHP Accelerator
4. XCache
5. Zend Optimizer+
6. Zend Platform
7. Zend Optimizer and Zend Guard Loader
8. Windows Cache Extension for PHP
Fisierele responsabile pentru acceleratoare le gasesti in

Cod: Selectaţi tot

phpBB3\includes\acm
.
acm_xcache.php este activat de catre $acm_type='xcache' daca la informatiile PHP gasesti xcache instalat.
Din experienta, am vazut ca cele mai multe firme instaleaza implicit eAccelerator.
Partea buna la folosirea unui accelerator este ca optimizeaza performanta prin eliminarea timpului de compilare a scripturilor PHP, prin utilizarea acesteia direct din memoria RAM. Acest lucru va creste rata de generare a unei pagini php, deoarece optimizeaza multe alte aspecte ale scripturilor php si reduce incarcarea de pe server.
Partea proasta este ca memoria chache din RAM se elibereaza mai greu si vor fi probleme la afisarea mesajelor noi, la schimbarile efectuate in fisiere forumului, etc
Ti-am scris aceste lucruri ca sa stii cam cu ce se mananca, insa flowers a fost mai sec si in concluzie spun si eu acelasi lucru:
Lasa forumul unde este, si dupa salvarea fisierelor si a bazei de date poti face update la 3.0.11

Avatar utilizator
danpetreanu
Junior
Junior
Mesaje: 33
Membru din: 19-Sep-2008, 22:50:29
MOD: Nu
Server: Windows
Nivel phpBB: Mediu
Nivel php: Mediu
Localitate: Bucuresti
Contact:

Re: Mutare forum pentru update de la 3.0.2 la 3.0.11

Mesaj de danpetreanu » 20-Dec-2012, 16:20:53

Inca o data, va foarte multumesc tuturor!

Intr-adevar, am reusit sa fac update-ul la 3.0.11. Nu mi-a mers pana acum din pricina conexiunii mele "extraordinare" la net care dadea rateuri la ultimul pas - inlcuirea automata a fisierelor pe ftp. Pana la urma am downloadat pachetul pe care mi-l dadea ca si varianta aplicatia de update, le-am inlocuit manual fisierele si am updatat baza de date.

Merge ca uns :)

visualstorm esti un ZEU!!!

Spor!

visualstorm
Membru
Membru
Mesaje: 219
Membru din: 29-Apr-2007, 00:12:47
Versiune: 3.0.12
MOD: Da
Server: UNIX/Linux
Nivel phpBB: Experimentat
Nivel php: Mediu

Re: Mutare forum pentru update de la 3.0.2 la 3.0.11

Mesaj de visualstorm » 22-Dec-2012, 07:28:35

Ei, nici chiar asa! Nu prea am timp, insa vreau sa ajut oamenii care doresc sa invete!
Sarbatori fericite!

Închis

Înapoi la “3.0.x Instalare, actualizare, conversie”

Cine este conectat

Utilizatori ce ce navighează pe acest forum: Niciun utilizator înregistrat și 1 vizitator