error in posting (functions_post.php)

Discuţii legate de instalarea şi funcţionarea unor MODificări vechi sau noi ale forumului phpBB 2.0.x.
Închis
Avatar utilizator
Giuli
Iniţiat
Iniţiat
Mesaje: 76
Membru din: 27-Mar-2008, 17:47:47

error in posting (functions_post.php)

Mesaj de Giuli » 28-Mai-2008, 14:10:51

Ieri am incercat sa pun admin colors si mi-a dat o eroare ciudata si nu am stiut ce sa`i fac..am scos tot ce am modificat,mi-a mers o zi si acum imi dao noua eroare!
Error in posting

DEBUG MODE

INSERT INTO phpbb_posts (topic_id, forum_id, poster_id, post_username, post_time, poster_ip, enable_bbcode, enable_html, enable_smilies, enable_sig) VALUES (419, 2, 2, '', 1211976616, '5922567f', 1, 1, 1, 1)

Line : 240
File : functions_post.php
am pus si un functions_post.php nou si tot la fel face,am incercat si din install sa pun fisierele de la instalarea phpbb dar nici un rezultat,am pus forumul din nou si am restaurat din backup,in momentul cand pun din backup apar toate posturile si userii dar imi da aceeasi eroare ,ce pot sa fac sa scap de ea?? nu vreau sa-mi pierd userii m-am chinuit mult sa-i aduc,va rog daca aveti vrei sugestie sa ma ajutati si pe mine

Avatar utilizator
dorin
Guru
Guru
Mesaje: 4620
Membru din: 24-Iun-2003, 22:23:29
Versiune: 3.1.10
MOD: Da
Server: UNIX/Linux
Nivel phpBB: Mediu
Nivel php: Puţin experimentat
Contact:

Mesaj de dorin » 29-Mai-2008, 16:20:12

Pai vezi ca numele utilizatorului pe care vrea sa-l insereze in BD este gol
...2, 2, '', 1211976616 ...
Ar trebui sa restaurezi toate fisierele modificate inainte de a instala modificarea.

Posteaza un link catre MOD-ul instalat.

Avatar utilizator
Giuli
Iniţiat
Iniţiat
Mesaje: 76
Membru din: 27-Mar-2008, 17:47:47

Mesaj de Giuli » 30-Mai-2008, 10:23:41

dorin scrie:Pai vezi ca numele utilizatorului pe care vrea sa-l insereze in BD este gol
...2, 2, '', 1211976616 ...
Ar trebui sa restaurezi toate fisierele modificate inainte de a instala modificarea.

Posteaza un link catre MOD-ul instalat.
am scos toate mod-urile instalate inainte sa`mi dea eroarea asta..chiar sunt unele fisiere din instal dar tot am aceea eroare,am incercat si cu repair.php tot degeaba! dorin spune`mi de ce anume ai nevoie am mare nevoie de ajutor pierd userii inscrisi...uite un id de mess g1uli

Avatar utilizator
Muzet
Fost coleg
Fost coleg
Mesaje: 2295
Membru din: 18-Mar-2008, 23:29:52
Versiune: 0.0
MOD: Nu
Server: UNIX/Linux
Nivel phpBB: Experimentat
Nivel php: Experimentat

Mesaj de Muzet » 30-Mai-2008, 10:30:48

Ai o bază mai veche, pe care ai salvat-o înainte să ai erorile pe forum?
Dacă da şterge tabelul phpbb_posts din phpMyAdmin, deschide fişierul de la baza de date (cea veche) şi caută tabelul phpbb_posts, apasă pe al II-lea buton aflat în partea de sus a paginii în stânga şi bagă codurile din bază, de unde începe phpbb posts până unde se termină.

Avatar utilizator
dorin
Guru
Guru
Mesaje: 4620
Membru din: 24-Iun-2003, 22:23:29
Versiune: 3.1.10
MOD: Da
Server: UNIX/Linux
Nivel phpBB: Mediu
Nivel php: Puţin experimentat
Contact:

Mesaj de dorin » 30-Mai-2008, 16:26:03

Am incercat sa-l ajut, am luat din ACP tabela phpbb_post (nu am avut acces la cPanel) si structura ei e corecta, insa datele din ea sunt alterate de aceeasi problema la campul post_username:

Cod: Selectaţi tot

INSERT INTO phpbb_posts (post_id, topic_id, forum_id, poster_id, post_time, poster_ip, post_username, enable_bbcode, enable_html, enable_smilies, enable_sig, post_edit_time, post_edit_count) VALUES('2', '2', '2', '2', '1206577489', '59225733', '', '1', '0', '1', '0', NULL, '0');
Totusi forumul afiseaza corect mesajele si autorii acestora, nu ar trebui sa fie erori si la afisare ? Sau post_username e luat din alta tabela la afisare ?

Ce este ciudat: am gasit cateva inregistrari (3-4) care au campul post_username completat, asa ca nu pot intelege ce a cauzat problema asta. Din pacate nu are nici un backup la baza de date.

Închis

Înapoi la “2.0.x Suport pentru MODificări”