Pagina 1 din 1

phpBB 3.1 "Ascraeus" va necesita minim PHP 5.3.3

Scris: 11-Mar-2012, 17:32:51
de dorin
Urmatoarea versiune majoră a phpBB, phpBB 3.1 "Ascraeus", va necesita PHP versiunea 5.3.2 sau mai nouă.

PHP 5.3 oferă funcţionalități importante ce sunt folosite de un număr semnificativ de proiecte. Cum unul din scopurile phpBB este de a folosi componente de la alte proiecte în cazul în care acest lucru are sens, creşterea versiunii minime de PHP la 5.3 va permite reutilizarea unor componente de la Symfony în loc de reimplementarea unor funcţionalitați echivalente. Acest lucru va accelera finalizarea phpBB 3.1 prin reducerea cantitatii de muncă pe care echipa de dezvoltare phpBB ar trebui să o facă.

Puteți să citiți discuția care a condus la aceasta decizie aici.

Toate distribuţiile majore de PHP 5.3.2 sau mai recente sunt stabile. Puteţi găsi un tabel cu distribuţiile şi versiunile aici.

PhpBB 3.0 "Olympus", va continua să necesite PHP 4.3.3 ca versiune minimă.

PhpBB 3.0.10 suporta PHP 5.3. Începând cu data la care PHP 5.2 nu va mai fi întreținut de dezvoltatorii PHP, toţi utilizatorii care nu folosesc deja PHP 5.3 sunt încurajați să migreze la PHP 5.3.

Cum phpBB 3.1 "Ascraeus" este încă în curs de dezvoltare activă, există timp suficient pentru a actualiza instalarea PHP.

În plus, ar trebui să reţineţi că acest anunţ nu implică faptul că phpBB 3.1 va avea porţiuni mari de cod rescrise, în scopul de a profita de noile caracteristici ale PHP 5.3. În schimb, secţiuni de cod vor fi actualizate în ciclul de lansare 3.x, potrivit necesităților.

Link către anunțul oficial phpbb.com :arrow: aici.

Re: phpBB 3.1 "Ascraeus" va necesita minim PHP 5.3.2

Scris: 02-Aug-2013, 19:15:54
de Ivan Petre Paul
S-a decis o modificare privind versiunea necesară lansării următoarei versiuni majore, phpBB 3.1 „Ascraeus”, din nou, și va necesita PHP 5.3.3 sau o versiune mai nouă.

Conform anunțului anterior s-a propus introducerea unor componente 3rd party în phpBB și, prin urmare, s-a anunțat creșterea minimului obligatoriu al versiunii PHP la 5.3.2. Cu toate acestea, Symfony a fost actualizată iar cerințele minime au fost de asemenea actualizate la scurt timp după aceea. Codul phpBB se bazează acum pe modificările efectuate după ce necesarul versiunii PHP a crescut.

Discuția care a dus la această decizie poate fi găsită pe Area51.